Sumar sólo números positivos

Las funciones matriciales hacen que Calc se comporte de un modo especial, pues evalua de forma independiente cada valor del rango de celdas indicado.

Por ejemplo, si deseas sumar tan sólo los números positivos en un rango de celdas puedes:

Utilizar la función SUMAR.SI

Esta función suma los números de un rango de celdas si se cumple una condición, que puede ser que esos mismos números sean positivos.

Ejemplo: sumar los números positivos en el rango A1:A10 y mostrar el resultado en la celda B5; en la celda B5 editaremos la fórmula =SUMAR.SI(A1:A10;">0";A1:A10)

Utilizar funciones matriciales

Ejemplo: sumar los números positivos en el rango A1:A1o y mostrar el resultado en la celda C5; en la celda C5 editaremos la fórmula =SUMA(SI(A1:A10>0;A1:A10;0)), pero en lugar de finalizar la edición pulsando Intro o desde el botón Validar de la barra de fórmulas, pulsaremos la combinación de teclas Mayúsculas + Ctrl + Intro.

Esta combinación indica a Calc que se trata de una fórmula matricial; en la barra de fórmulas se mostrará la fórmula encerrada entre llaves. {=SUMA(SI(A1:A10>0;A1:A10;0))}

Otro ejemplo

Supón una lista de números en el rango K5:K15, y una segunda en el rango L5:L15. Pretendes sumar para a par los números de ambas listas en el rango J5:J15.

Utilizando una fórmula y copiando

En la celda J5 insertas la fórmula =K5+L5. Posteriormente, copias la fórmula en el rango J6:J15, o bien, arrastras el manejador cuadrado negro de la celda para extender la fórmula al rango.

Utilizando una fórmula matricial

En la celda J5 insertas la fórmula =K5:K15+L5:L15 y finalizas la edición con la combinación de teclas Mayúsculas + Ctrl + Intro. La fórmula matricial se extenderá automáticamente en el rango J5:J15

Puedes descargarte una hoja de Calc ejemplo Ejemplos_Sumar_SI_Formula_Matricial.zip

 

3 comentarios

Comentario De: ENRIQUE VILLALTA [Visitante]

Muchas gracias por la ayuda. Se le agradece bastante....

11.11.13 @ 03:47
Comentario De: henry leon rivera [Visitante]

la formula está bien, pero que pasa si es que en esa BD quiero hacer la suma de nros positivos mediante una busqueda de un solo codigo de producto

21.05.16 @ 03:54
Comentario De: [Miembro]

=SUMA(SI( Y( A1:A10>0 ; B1:B10="CODIGO") ;A1:A10;0))

22.05.16 @ 09:56


Form is loading...