Bienvenidos a open-office.es, web no oficial en español para OpenOffice y derivados

Calcular años, meses y días entre dos fechas

Para calcular el número de años, meses o días transcurridos entre dos fechas en OpenOffice.org Calc puedes utilizar las siguientes funciones:

AÑOS( FechaInicial; FechaFinal; Tipo), siendo Tipo = 0, o también

AÑO( FechaFinal ) - AÑO( FechaInicial), pero no tiene en cuenta el día y mes de las fechas.

 

MESES( FechaInicial; FechaFinal; Tipo), siendo Tipo = 0, o también

(AÑO(FechaFinal)-AÑO(FechaInicial))*12+MES(FechaFinal)-MES(FechaInicial), pero no tiene en cuenta el día de las fechas

 

DIAS( FechaFinal; FechaInicial ) o, simplemente restando de la fecha final la inicial.

 

Si quieres calcular el número de años, meses y dias transcurridos entre dos fechas:

 

AÑOS(B4;C4;0) & " AÑOS " & (MESES(B4;C4;0)-(12*(AÑOS(B4;C4;0))) & " MESES " & ABS(DÍA(C4)-DÍA(B4)) & " DIAS"), o ...

 

AÑOS(B4;C4;0) & " AÑOS " & (MESES(B4;C4;0)-(12*(AÑOS(B4;C4;0))) & " MESES " & ABS(DÍA(C4)-DÍA(B4))+1 & " DIAS") si incluyes el último día.

 

Ejemplo: Anyos_meses_dias.zip

 

4 comentarios

Comentario De: Josué [Visitante]
Muchas gracias No sabía cómo hacerlo
03.06.11 @ 23:07
Comentario De: Justo Cárdeno [Visitante]
La formula propuesta para obtener los día comete un error cuando el día de la fecha inicial es mayor que el día de la fecha final.

Si en A6 esta la fecha inicial y en B6 esta la fecha final, las funciones para calcular los años, meses y días que hay entre las dos fechas serían:

años: =AÑOS(A6;B6+1;0)
meses: =MESES(A6;B6+1;0)-(12*AÑOS(A6;B6+1;0))
días: =DÍA(B6+1)-DÍA(A6)+SI(DÍA(A6)>DÍA(B6);DÍASENMES(A6);0))

si no quieres incluir el último día sería:

días: =DÍA(B6)-DÍA(A6)+SI(DÍA(A6)>DÍA(B6);DÍASENMES(A6);0)


22.06.11 @ 20:43
Comentario De: framis [Visitante]
¿Hay alguna forma para que el resultado se mostrara con un 0 delante si es menor de 10?

Por ejemplo: 03 años 04 meses 08 días

Ya que la fórmula me arroja 3 años 4 meses 8 días y si quiero ordenar esa columna (de menor a mayor) me aparece antes un 3 años 4 meses y 12 días que el dicho anteriormente.
29.01.14 @ 18:19
Comentario De: slv-es [Miembro] · http://open-office.es
Puedes utilizar la función TEXTO( número; formato )

=TEXTO(AÑOS(B4;C4;0);"00") & " AÑOS " & TEXTO((MESES(B4;C4;0)-(12*(AÑOS(B4;C4;0)));"00") & " MESES " & TEXTO(ABS(DÍA(C4)-DÍA(B4));"00") & " DIAS")

Consulta Formatos personalizados para conocer los formatos personalizados que puedes utilizar.
30.01.14 @ 13:58

Dejar un comentario


Tu dirección email NO será mostrada en este sitio.
(Saltos de línea se convierten a <br />)
(Nombre, email y página web)
(Permitir que los usuarios contacten contigo vía un formulario de mensajes; tu email NO se hará público)

Otros visitantes vieron...

Patrocinado por SBS  • © 2015 by slv-es