Uso de las funciones SUMAR.SI y CONTAR.SI con expresiones regulares

Usar expresiones regulares en las funciones SUMAR.SI y CONTAR.SI

Las funciones SUMAR.SI y CONTAR.SI son muy útiles, pero mucho más si las utilizamos con expresiones regulares.

En el modelo que presentamos podemos observar en la columna Referencia distintos productos en los que su descripción contiene una característica relevante para nuestras necesidades: el color.

Deseamos sumar las unidades de un color determinado, que escribimos en la celda C13. El resultado se muestra en la celda C14. También necesitamos saber cuantas referencias existen de ese color, resultado que se muestra en la celda C15.

 

 

 

 

Para conseguir el resultado de la celda C14 utilizaremos la función SUMAR.SI:
=SUMAR.SI(B3:B10;".*" & C13 & ".*";C3:C10)

En cambio, para conseguir el resultado de la celda C15 utilizaremos la función CONTAR.SI

=CONTAR.SI(B3:B10;".*" & C13 & ".*")

El segundo argumento de ambas funciones es una expresión regular, como ".*ROJO.*" que equivale a decir "toda aquella celda que contenga la palabra ROJO al principio, final o dentro de su contenido. Dado que el color lo especificamos en la celda C13, utilizamos el operador & para conseguir la expresión regular, agregando antes y después del contenido de la celda las expresiones ".*".

Muy importante: para que todo esto funcione deberá estar activado el uso de expresiones regulares en las fórmulas de Calc. Para ello, desde el menú Herramientas > Opciones > OpenOffice.org Calc > Calcular activaremos la opción Permitir expresiones regulares en las fórmulas.

+info en Wiki oficial de OpenOffice

2 comentarios

Comentario De: Mauricio López [Visitante]

Excelente explicación. Concisa y precisa. Muchas gracias.

13.08.14 @ 03:08 Reply to this comment
Comentario De: Francisco José [Visitante]

La última referencia de "Muy importante" me "ha salvado la vida", había leído como hacerlo pero me salía error o no "contaba" bien hasta que he visto la modificación a realizar en las Herramientas en esta página.
Aunque sea tres años después, muchas gracias.
Fran.

10.10.14 @ 12:58 Reply to this comment


Form is loading...